rear ballast bag not fully draining??? Log Out | Topics | Search | Register | Edit Profile | User List
Last Day | Last Week | Tree View | Moderators | Help/Instructions
WakeWorld Discussion Board » >> Boats, Accessories & Tow Vehicles Archive » Archive through July 28, 2009 » rear ballast bag not fully draining??? « Previous Next »
By SJ (jixxxer) on Thursday, July 23, 2009 - 2:10 pm:    Edit Post Delete Post
I have a fat seat in the rear of the boat and a 750 bag in the bow; When it comes time to drain the bow does fine cause the water is directed right to the drain fitting but the rear bag does fine until the water is more in the rear of the bag and the pump is just sucking air which doesnt like that. There is no connection in the rear of the bag to ease the problem, I was wondering how do the factory bags drain complete????
 
By tampawake (tampawake) on Thursday, July 23, 2009 - 2:20 pm:    Edit Post Delete Post
my center sack drains till its sucking water in my xstar. I pull the bag up so that it drains completely. I think that is just what you get with the bag type set up
 
By Nacho (denverd1) on Thursday, July 23, 2009 - 2:22 pm:    Edit Post Delete Post
You can add your own port if you can find a good spot to do it (lower on the sac, on one end so you concentrate the water there, whatever). Just buy a plastic thru-hull and some marine sealant. Cut a hole just big enough that the mushroom end will fit into the bag, squirt you sealant on the inside, then on the back of the thru-hull fitting, tighten her up.
 
By Psyclone (cyclonecj) on Thursday, July 23, 2009 - 6:41 pm:    Edit Post Delete Post
I did exactly what Nacho describes on two fat seats, works great.
 

Topics | Last Day | Last Week | Tree View | Search | User List | Help/Instructions Administration
Privacy Policy | Terms of Use
WakeSpace is owned by eWake, Inc.
Copyright © 1996 - 2010, All Rights Reserved.
WakeSpace@WakeWorld.com