Bilge Help Log Out | Topics | Search | Register | Edit Profile | User List
Last Day | Last Week | Tree View | Moderators | Help/Instructions
WakeWorld Discussion Board » >> Boats, Accessories & Tow Vehicles Archive » Archive through July 28, 2009 » Bilge Help « Previous Next »
By Joe Curtis (jcurtis) on Tuesday, July 21, 2009 - 3:51 pm:    Edit Post Delete Post
I have a 99 Maristar with a yellow and black bilge pump, the pump is a cartridge type with a square float device. When in the Auto mode the float will not activate the pump, either by hand or when we get a little water in it. It does work when I flip the switch to on. I would get the brand of it, but it is at the lake, which is two hours away. I am trying to get the make of this so I can get the float switch and replace this weekend as it will be on a buoy for a week. Any help is appreciated
 
By Doug P (dpolen) on Tuesday, July 21, 2009 - 7:46 pm:    Edit Post Delete Post
I'll be at my boat tomorrow (same boat, but '98), will try to take a look to get you what you need to order a new one.
 
By Joe Curtis (jcurtis) on Tuesday, July 21, 2009 - 9:40 pm:    Edit Post Delete Post
thanks Doug
 
By Doug P (dpolen) on Wednesday, July 22, 2009 - 4:54 pm:    Edit Post Delete Post
Joe,
I think this is what you need. Pretty sure its a Mayfair bilge pump. Couldn't figure out exactly what the GPH was, but guessing 750. Hope this helps, good luck!

Here's a link to one on the web...
http://www.nextag.com/MayFair-Ultima-Combo-Pumps-551504304/prices-html

 

Topics | Last Day | Last Week | Tree View | Search | User List | Help/Instructions Administration
Privacy Policy | Terms of Use
WakeSpace is owned by eWake, Inc.
Copyright © 1996 - 2010, All Rights Reserved.
WakeSpace@WakeWorld.com