Perfect Pass speed control reliabilit... Log Out | Topics | Search | Register | Edit Profile | User List
Last Day | Last Week | Tree View | Moderators | Help/Instructions
WakeWorld Discussion Board » >> Boats, Accessories & Tow Vehicles Archive » Archive through April 21, 2006 » Perfect Pass speed control reliability I/O « Previous Next »
By Chad Druffel (dedicatedwse) on Saturday, April 15, 2006 - 7:30 pm:    Edit Post Delete Post
I bought and am about to install PP on a V-hull I/O. I've heard about problems with the speed control on certain Malibus due to waterflow issues at the paddlewheel.

Who has installed PP on an I/O, and did you have speed control problems that weren't able to be corrected by a PP technical service rep?

Thanks

 
By gordon (gmarkham1) on Sunday, April 16, 2006 - 8:02 am:    Edit Post Delete Post
i had it installed on a 2000 bayliner capri 1850.
i did havve speed control problems and we ran in rpm mode for the most consistent pull.
The paddle wheel was right in front of the engine... i think if it could have been located further back it would have been better.
the problem was every time i thougt i had the settings perfect a variable like weight in the boat, the person being pulled, goin up river instead of down would change how well it was working.

it was still worth it to use in rpm mode, and i think it would perform better on a larger boat with A larger motor!

 
By DC (dan_forrest) on Sunday, April 16, 2006 - 8:53 am:    Edit Post Delete Post
Chad, I have been considering doing the same thing on my V-hull. Haven't bought PP yet though. Let me know how it goes and what you think of it when your done.
 
By Bob (bob) on Sunday, April 16, 2006 - 8:57 am:    Edit Post Delete Post
Have had it for 4 years on a 20' monterey. Only problem I have is if you try to take a very sharp turn it needs some help but regular wake boats have that problem too. Make sure you mount the paddle wheel as per the manufacturer.
 
By Druffel (dedicatedwse) on Monday, April 17, 2006 - 9:37 pm:    Edit Post Delete Post
Anyone else have experience to share?
 
By Manzo (zo1) on Tuesday, April 18, 2006 - 6:17 am:    Edit Post Delete Post
We had it on our old '88 Baja. We used it in speed mode and it was worth every penny!!!
 
By Mike Usner (musner) on Wednesday, April 19, 2006 - 9:20 pm:    Edit Post Delete Post
I installed one on my 2001 Larson 4.3EFI three years ago. I had to fiddle with the settings for a bit, but once I got it dialed in, it worked great. Best purchase for the boat I've made.

 
By Druffel (dedicatedwse) on Thursday, April 20, 2006 - 12:34 pm:    Edit Post Delete Post
I'm installing this weekend...
 
By Todd Brown (t_brown) on Thursday, April 20, 2006 - 12:47 pm:    Edit Post Delete Post
do they work on Carbed 5.0 liter boats?
 
By gordon (gmarkham1) on Thursday, April 20, 2006 - 12:52 pm:    Edit Post Delete Post
http://www.perfectpass.com/inboardoutboard.html

yes!

 
Topics | Last Day | Last Week | Tree View | Search | User List | Help/Instructions Administration
Privacy Policy | Terms of Use
WakeSpace is owned by eWake, Inc.
Copyright © 1996 - 2008, All Rights Reserved.
WakeSpace@WakeWorld.com