WetBox's XTI install Log Out | Topics | Search | Register | Edit Profile | User List
Last Day | Last Week | Tree View | Moderators | Help/Instructions
WakeWorld Discussion Board » >> Boats, Accessories & Tow Vehicles Archive » Archive through April 21, 2006 » WetBox's XTI install « Previous Next »
By Nick Heckendorf (wetone) on Monday, March 20, 2006 - 5:19 pm:    Edit Post Delete Post
Time to refresh the system in the XTI. All sub enclosures will be painted with blue LED's. Custom amp racks and batterie tray. And a customized WetBox on the tower.
Now all we need is a mericle to finish by Spring Ride.

System Breakdown

(4) JL 10w6's
(1) JL 15w3
(4) JL M770's interior spk.
(5) Eclipse XA1000 amps
(2) DA6213 amps
(4) Batteries
(1) alternator upgrade
LED's under the swimstep and throught the boat and sub enclosures

Tower speakers and enclosure ?????

Afew pics of the teardown.Upload
Upload
Upload
Upload


(Message edited by wetone on March 20, 2006)

 
By Squid (twakess) on Monday, March 20, 2006 - 5:29 pm:    Edit Post Delete Post
Nick, I didn't know you still had that boat. Your poor pops ears. We need to hit up the lake like we did in the good old days. Maybe we can get Jason back on the dock trying to sell everyone a box. Good times
 
By Sound_Illusions (grant_west) on Monday, March 20, 2006 - 5:41 pm:    Edit Post Delete Post
Nick : Im glad to see in True WETBOX style you started your install with only 3 weeks untill the Boat Show. You are the man.

 
By richard estevo (mendo247) on Monday, March 20, 2006 - 5:57 pm:    Edit Post Delete Post
nice tool box!
 
By Nick Heckendorf (wetone) on Wednesday, March 22, 2006 - 5:26 pm:    Edit Post Delete Post
A few pics of the flush mounted amps in the walkthroughUpload
Upload

 
By Jared Aubrey (jaubrey) on Wednesday, March 22, 2006 - 6:15 pm:    Edit Post Delete Post
That amp mounting is badd. I love the look and it being almost flush is great. Keep the pictures coming!
 
By Ben Kerran (rukie) on Thursday, March 23, 2006 - 8:54 am:    Edit Post Delete Post
Nick,
Amp install looks sweet. Let us know how you like the JL M770's. I am leaning towards using a bunch of them in my boat and would love to hear some feedback. Keep the pics coming

 
By Nick Heckendorf (wetone) on Thursday, March 23, 2006 - 10:35 am:    Edit Post Delete Post
Ben,

The JL M770's are loud and sound great with the right amount of power. The only problem is they are on backorder from JL because MasterCraft is purchasing moste of them. I have 2 pair now and dont know if I will get the outhers to finish the boat soon.

 
By Ben Kerran (rukie) on Thursday, March 23, 2006 - 10:51 am:    Edit Post Delete Post
Thanks Nick. I am definitely leaning towards going with the m770's. I have just enough clearance from the floor in the stock speaker locations in my boat to use them. The back order situation sucks. I have been looking online and they seem to be in stock however I have only been price searching at this point and have not placed an order yet. Thanks again for the info and keep us updated on your install.
 
By Joe B (jbwaken) on Thursday, March 23, 2006 - 12:54 pm:    Edit Post Delete Post
Nick very nice custom job on the amp...
 
By J (biker_jimm) on Friday, March 24, 2006 - 6:55 am:    Edit Post Delete Post
I had thought of a sub where you have mounted those amp's or at least on the drivers side, That looks very good tho.
 
Topics | Last Day | Last Week | Tree View | Search | User List | Help/Instructions Administration
Privacy Policy | Terms of Use
WakeSpace is owned by eWake, Inc.
Copyright © 1996 - 2008, All Rights Reserved.
WakeSpace@WakeWorld.com