Amp Installion help? Log Out | Topics | Search | Register | Edit Profile | User List
Last Day | Last Week | Tree View | Moderators | Help/Instructions
WakeWorld Discussion Board » >> Boats, Accessories & Tow Vehicles Archive » Archive through April 01, 2004 » Amp Installion help? « Previous Next »
By Aaron Bell (aaron_bell) on Wednesday, March 24, 2004 - 8:58 pm:    Edit Post Delete Post
Where and how are you guys grounding your amps?
Are you ruuning a separte wire back to the battery or taping into the fuse box? This install is for a SAN if that is any help. I thought I could tap into the fusebox, I guess that is the term for the box located in front of the drivers legs. Any help is greatly appreciated!

 
By Mike (bigdeal) on Wednesday, March 24, 2004 - 9:06 pm:    Edit Post Delete Post
Best way to handle it is to run a ground wire to the negative terminal on your battery. Just make sure you size that wire properly. Most boats will have their main ground running from the negative post on the battery to some location on the engine block.
 
By TR (biz) on Thursday, March 25, 2004 - 9:13 am:    Edit Post Delete Post
Either the negative terminal on your battery or the Engine Block ground, never the fuse box.
 
By Aaron Bell (aaron_bell) on Thursday, March 25, 2004 - 8:40 pm:    Edit Post Delete Post
Thanks! That should be no problem.
 
Topics | Last Day | Last Week | Tree View | Search | User List | Help/Instructions Administration
Privacy Policy | Terms of Use
WakeSpace is owned by eWake, Inc.
Copyright © 1996 - 2008, All Rights Reserved.
WakeSpace@WakeWorld.com